Foresight Patient Chat Unavailable

Incident Report for Codex Health

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 17:29 PDT

Investigating

Posted Apr 17, 2025 - 13:20 PDT
This incident affected: Foresight (Chat) and Allie (Chat).